Jump to content

New Megane II RS owner


btechAU
 Share

Recommended Posts

Well, g'day everyone.

Finally getting around to posting. I've been lurking here for a little while as I've been considering what car to start my track car adventure with. I've considered WRX, Golf GTI, Astra SRi, etc, but kept returning to the Megane 225. So after searching for a while, I ended up finding a tidy (to the eye at least) 2007 Red Megane II 225 on GraysOnline and picked it up sight unseen and unchecked for a decently cheap price at the beginning of August. Then came the realisation that maybe I'm a fool, but in for a penny in for a pound, right? :D

So on the back of the truck it arrived in Sydney nearly 2 weeks later, looking a bit rough and dirty, but overall pretty tidy. First drive seemed pretty good (at least it drove right? 8))

Next day down to my local mechanic for a check up and blue slip. Turned out that the old girl didn't pass. 4 bold tyres, a couple of bulbs, non-working windscreen washers and worn inner tie rods. Also one of the coil pack clips had pretty much disintegrated. So I got to spend only one evening with her and then she was at the shop for 2 weeks. The mechanic tried to get aftermarket tie rods, but they sent him 3 sets (one after the other) that were too short, didn't have the joints, and too long. Hi finally gave up and just got the genuine ones. I would've done them myself probably but since it wasn't rego'd and already in the shop... It also has a rough idle issue, but he says the engine mounts seem fine so he put some injector cleaner through it and said let's see.

In the end, the bill was a fair hit in the hip pocket, but considering the purchase price, I think I'm still ahead (a bit). :blink: In any case, the car is rego'd and after a good once-over with a clay bar, is really in quite the excellent condition for it's age and KMs. I've been driving it this week to work so I could get a feel for it and to see if anything else came up. The check engine light has on two separate occasions flashed for about 10-15 seconds, but has always gone away for days in-between. When he checked it over he said no fault codes, so hopefully it doesn't turn into anything major.

The car has all of it's service records and receipts and on the last one they noted "timing belt overdue" so I guess I'll be up for another hit shortly. As per some others, I can't for the life of me tell if the car is a Cup or not. It has Xenons, the 18" wheels, and the TC stays off, but seems to only have Brembos on the front. I haven't looked at the springs/shocks yet... It also has the orange belts, but has leather seats. No sunroof and no "CUP" designation on the door sills or codes. So - no idea. It's like 50/50.

As I've been driving it this week, I am now convinced that the shake on idle is only when the car is facing uphill on an incline. I'll post separately about this to see if anyone has any ideas. Otherwise she drives real nice.

I should clarify that the car is intended to be a track car and not a regular daily driver but I'll be working my way up to it over time.

So, it's good to be here and looks like it's a great little community, glad to be part of it. The journey begins. If you see me on the road, give us a wave. Pic below.

Cheers,
B.

20170910_175724s.thumb.jpg.fedd2de28fab8e0f403c39fea07dfff8.jpg

 

  • Like 5
Link to comment
Share on other sites

Welcome and nice pick up mate! Where abouts you located?
I'm fairly certain that's the Cup then because they came with anthracite mirrors too, however I thought they came with silver seat belts haha. We have a track day on Wednesday at Wakefield park, have a look in the Advanced Driving section.

Link to comment
Share on other sites

58 minutes ago, Viv said:

Welcome and nice pick up mate! Where abouts you located?
I'm fairly certain that's the Cup then because they came with anthracite mirrors too, however I thought they came with silver seat belts haha. We have a track day on Wednesday at Wakefield park, have a look in the Advanced Driving section.

Cheers Viv. You're right, I'm colour blind. The belts are silver. Duh. I must've had orange on the brain. :lol: And yes, the anthracite mirrors and wheels. (the previous owner painted them black but you can see the anthracite in spots.) Bummer, I can't make this Wednesday because of work but I'll be keeping a close eye on the forums for the next opportunity!

ps. I'm in the Hills area of Sydney

Link to comment
Share on other sites

Welcome to the forum, your 225 looks great. 

Rule 1 of  Car Nuts' Handbook: don't add up what you spend on your car!
 
I had a head-scratch about your idle shake problem and I can't think of anything much useful to say but I'll put some blather up in your other thread anyway.
 
Dooook's too kind. I was going to say to look at his 225 thread to see a really quick Meg 2. They make a better track car than road car in my opinion, even when near-stock, especially if you already have cup suspension.
 
I hope to see you at a track day soon.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...